South Africa: Card Transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 19, 2023 - 06:29 CET
Monitoring
Success rates are currently stable. The issue has been escalated to 3rd-party partners for further investigation. We will continue to monitor.
Posted Apr 19, 2023 - 05:09 CET
Investigating
We are seeing in increase in failure rates for card transactions. We are investigating the issue.
Posted Apr 19, 2023 - 04:49 CET
This incident affected: Transactions (Cards).