Nigeria: Unable to access Paystack's services via the Fiberone network

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 15:21 CET

Investigating

Users on Fiberone's network in Lagos, Nigeria are currently unable to access Paystack's services, including the Dashboard and Checkout.

Our services are fully operational and accessible. In the meantime, you may consider using an alternative internet provider to access Paystack's services.

We are working with Fiberone to fix this issue as soon as possible.

We'll continue to monitor the situation closely and keep you updated.
Posted Jul 08, 2025 - 12:56 CET
This incident affected: Checkout and Dashboard.