BVN Service Failure
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 05, 2019 - 14:53 CET
Monitoring
We have begun receiving valid responses for BVN verification. We are monitoring the situation to confirm the uptime is stable
Posted 3 months ago. Jun 05, 2019 - 08:44 CET
Investigating
We are currently encountering an issue where calls to the central BVN service are failing intermittently. We have escalated to the service and are awaiting a resolution
Posted 3 months ago. Jun 04, 2019 - 13:51 CET
This incident affected: API.