Paystack Kenya: Downtime on M-PESA transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 13:03 CET
Investigating
We have noted an increased failure on M-PESA transactions.
M-PESA is currently experiencing technical hitches affecting their services country-wide. Their technical team is working to resolve it urgently.
Posted Jan 09, 2024 - 10:33 CET
This incident affected: Transactions (Mobile Money).