Paystack Merchant Dashboard
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 30, 2023 - 12:00 CET
Monitoring
The issue has been identified and remediated. The team continues to monitor our services.
Posted Apr 30, 2023 - 10:43 CET
Investigating
We are currently aware of an incident impacting your ability to log into the dashboard. A team is investigating this issue.
Posted Apr 30, 2023 - 10:01 CET
This incident affected: Dashboard.