A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2025 - 23:34 CET
Update
Our partner MTN is still investigating the issue. We are monitoring closely and will continue to share updates as soon as we get them.
Thank you for your patience so far.
Posted Aug 17, 2025 - 19:00 CET
Investigating
Our partner, MTN, is currently having a downtime on their platform, which is affecting mobile money transactions at the moment. As a result, most MTN transactions are failing. We're currently liaising with them to fix the issues and restore the service.
Posted Aug 17, 2025 - 12:46 CET
This incident affected: Transactions (Mobile Money).