Delays with Transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 21:09 CET
Investigating
We are experiencing an issue with our Transfers product that is causing transfers to remain pending. Our Engineering team is currently looking into this.
Posted Aug 17, 2021 - 18:11 CET
This incident affected: Transfers.