Delay with transfers to Titan Trust accounts.
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 15:50 CET
Investigating
There's a delay in confirming credits for transfers into Titan Trust Bank accounts due to a temporary bank downtime. This will affect confirmation of deposits for Top Ups and Dedicated Virtual Account Numbers.

We're currently engaging and working with the bank to resolve.
Posted Mar 13, 2023 - 11:54 CET
This incident affected: Transactions (Virtual Account Numbers).