Payments failing on Paystack and difficulty in logging in to the Dashboard
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 09:19 CET
Update
Our team is still investigating the issue. In the meantime, we've rolled back some changes and all users should be able to access the Paystack Dashboard and Payment Pages without issues.

Payments via checkout are also working fine but you will be unable to receive payments via transfers (for Nigerian businesses) as we keep looking into the issue. Users might also have issues resolving our Wema virtual account numbers.

Our engineers are actively working on this and we'll continue to provide updates.
Posted Apr 19, 2021 - 12:29 CET
Investigating
Our team is currently investigating an issue causing payment attempts to fail as well as preventing businesses from logging into their Paystack Dashboard. We are continuing to investigate and will update this incident with more details as they are available.
Posted Apr 19, 2021 - 10:52 CET
This incident affected: API, Dashboard, Payment Page and Transactions (Checkout).