South Africa: 3D Secure degraded
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Feb 18, 2023 - 06:33 CET
Update
We are continuing to monitor for any further issues.
Posted Feb 17, 2023 - 16:50 CET
Monitoring
We are still seeing some failures related to Standard Bank, but success have stabilised. We will continue to monitor.
Posted Feb 17, 2023 - 16:35 CET
Identified
The issue only affects Standard Bank cards. It has been escalated to them.
Posted Feb 17, 2023 - 16:13 CET
Investigating
We are seeing an elevated level of failures for Mastercard transactions during the 3D Secure process. We have escalated the issue and will continue to monitor.
Posted Feb 17, 2023 - 15:48 CET
This incident affected: Transactions (Cards).