Nigeria: Temporarily failure in Direct Debit transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 09:35 CET

Investigating

Direct Debit transactions are temporarily failing due to an outage at our processing partner.

We're working closely with their team and expect to have the issue fully resolved shortly.
Posted Apr 23, 2025 - 15:24 CET
This incident affected: Transactions (Direct Debit).