South Africa: Degraded 3DS performance for Capitec-issued cards

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted May 14, 2025 - 12:58 CET

Monitoring

Success have been stable since 12:45 SAST. We will continue to monitor.
Posted May 14, 2025 - 12:10 CET

Investigating

We are seeing an increase in 3DS failures for Capitec-issued cards. The issue has been escalated to our 3rd-party partners.
Posted May 14, 2025 - 10:25 CET
This incident affected: Transactions (Cards).