A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 13:17 CET
Investigating
We have identified an outage with NIBSS affecting Account linking services. We are actively working with the NIBSS team to resolve the issue. We apologize for any inconvenience this may cause and will provide an update as soon as the service is restored.
Posted Sep 17, 2024 - 11:35 CET
This incident affected: Transactions (Direct Debit).