South Africa: Card Transactions

Incident Report for Paystack

Resolved

Card transactions are processing normally again
Posted Apr 16, 2023 - 05:55 CET

Investigating

Card transactions in South Africa are currently timing out. We are busy investigating the cause.
Posted Apr 16, 2023 - 05:19 CET
This incident affected: Transactions (Cards).