South Africa: Degraded 3DS performance for Capitec cards

Incident Report for Paystack

Resolved

Success rates have returned to normal since 9:27 SAST.
Posted Jun 30, 2025 - 08:44 CET

Investigating

We are seeing an increased rate of failure for 3DS transactions using Capitec-issued cards. The issue has been escalated to our 3rd-party partners.
Posted Jun 30, 2025 - 08:04 CET
This incident affected: Transactions (Cards).