South Africa: EFT transactions failing
Incident Report for Paystack
Resolved
The Ozow service has been restored.
Posted Jul 17, 2023 - 04:55 CET
Identified
The Ozow maintenance is still ongoing after their maintenance window has ended. We have escalated the issue to them and will keep the channel disabled until it is operational again.
Posted Jul 17, 2023 - 04:43 CET
This incident affected: Transactions (Pay with Transfer/EFT).