South Africa: Increase in 3DS failures
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jun 08, 2024 - 19:12 CET
Monitoring
Success rates have been stable since 18:22. We will continue to monitor.
Posted Jun 08, 2024 - 17:37 CET
Investigating
We've seen an increase in failures for 3DS transactions for Visa cards. We have escalated the issue to our 3rd-party partners.
Posted Jun 08, 2024 - 16:44 CET
This incident affected: Transactions (Cards).