Nigeria: Guaranty Trust Bank (GTBANK) Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Nov 14, 2024 - 11:31 CET

Investigating

We are seeing an increase in failure rates on Cards issued by Guaranty Trust Bank. This is due to an ongoing maintenance at the Bank.

We have notified the GTB team and are in close contact with them to resolve this issue as quickly as possible, we will provide an update as soon as it has been resolved.
Posted Nov 13, 2024 - 11:10 CET
This incident affected: Transactions (Cards).