South Africa: FNB 3D Secure transactions failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 22:08 CET
Identified
We are seeing an increased rate of failure for 3D Secure transactions on cards issued by FNB. The issue has been escalated to FNB.
Posted Oct 19, 2023 - 19:50 CET
This incident affected: Transactions (Cards).