South Africa: Nedbank degraded performance

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Feb 15, 2025 - 12:30 CET

Monitoring

Success rates have been stable for the last hour. We will continue to monitor.
Posted Feb 15, 2025 - 11:43 CET

Update

Success rates have improved since 10:35 SAST, but we are still seeing intermittent failures. We will continue to monitor.
Posted Feb 15, 2025 - 11:02 CET

Identified

Nedbank is working on resolving the issue.
Posted Feb 15, 2025 - 09:28 CET

Investigating

We are currently seeing an increase in card transaction failures via our acquiring partner, Nedbank. The issue has been escalated to our 3rd-party partners.
Posted Feb 15, 2025 - 09:01 CET
This incident affected: Transactions (Cards, QR).