South Africa: Increase in 3DS failures for Mastercard
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 24, 2024 - 14:56 CET
Monitoring
Success rates have been stable since 15:00 SAST. We will continue to monitor.
Posted Oct 24, 2024 - 14:34 CET
Investigating
We are seeing an increase in failed 3D Secure transactions for Mastercard cards. The issue has been escalated to our 3rd-party partners.
Posted Oct 24, 2024 - 11:42 CET
This incident affected: Transactions (Cards, QR).