The central switch has resolved the issue, and the system is now stable
Posted Sep 01, 2025 - 13:48 CET
Investigating
We're currently experiencing a downtime with the Direct Debit channel due to an issue with our processing partner. As a result, attempts to link new bank accounts and charge already linked accounts may fail.
We are working with our processing partner to resolve the issue and will share updates as soon as possible.
Posted Aug 25, 2025 - 11:48 CET
This incident affected: Transactions (Direct Debit).