Delay in Transfers into PT accounts by Titan Trust Bank.
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 14:35 CET
Identified
Transfers into PT accounts powered by Titan Trust Bank for Top Up purposes might be experiencing a delay. This is due to the inability of the Bank to send notifications at this time.

In the interim, please use alternative PT accounts such as Paystack Titan or Fidelity if you need to top up your Balance.

We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Mar 20, 2024 - 18:00 CET
This incident affected: Transfers.