Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 05, 2024 - 01:00 CET
Scheduled
Paystack will be undergoing scheduled maintenance of our card infrastructure on Saturday, October 5th for three hours between 2:00AM and 5:00AM SAST.
What does this mean for your business? This maintenance will affect card payment channels only. As a result, your customers might experience slight performance degradation when attempting to make card payments between 2:00AM and 5:00AM SAST on Saturday, October 5th.
Rest assured, your customers can still make payments using Apple Pay, Ozow EFT, Snapscan and Scan to Pay during this time.
We recommend notifying your team to ensure they are aware of the maintenance.
Posted Sep 30, 2024 - 13:26 CET
This scheduled maintenance affected: Transactions (Cards).