South Africa: EFT Ozow degraded performance
Incident Report for Paystack
Resolved
Ozow transactions are processing normally again.
Posted Nov 19, 2023 - 12:46 CET
Investigating
We are seeing an increased number of failures for EFT Ozow payments. The issue has been escalated to Ozow and they are busy investigating.
Posted Nov 19, 2023 - 11:45 CET
This incident affected: Transactions (Pay with Transfer/EFT).