Nigeria: Downtime on GTBank Card Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 14:00 CET

Investigating

We are seeing an increase in failure rates on Cards issued by GTBank. This is due to a downtime on the bank's end.

We have notified the GTBank team and are in close contact with them to resolve this issue as quickly as possible.
Posted Mar 03, 2025 - 11:59 CET
This incident affected: Transactions (Cards).