Downtime on Pay With Transfer transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 13, 2023 - 18:43 CET
Investigating
We’re experiencing an issue with a partner and we’re working with them to resolve it.
Posted May 13, 2023 - 17:06 CET
This incident affected: Transactions (Pay with Transfer/EFT).