Intermittent issues with card processing for Nigerian merchants
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 02, 2022 - 08:02 CET
Investigating
Due to a technical disruption, there might be intermittent declines in success rates. We are working with our partners to resolve this issue as quickly as possible and will provide an update as soon as the issue has been resolved.
Posted Nov 01, 2022 - 17:22 CET
This incident affected: Transactions (Cards).