South Africa: Increase in EFT failures

Incident Report for Paystack

Resolved

The channel has been re-enabled and success rates are back to normal.
Posted Oct 30, 2023 - 14:55 CET

Update

We are disabling the channel until the issue is resolved.
Posted Oct 30, 2023 - 12:54 CET

Investigating

We are seeing an increase in failures when initiating EFT payments. The issue has been escalated to Ozow.
Posted Oct 30, 2023 - 12:49 CET
This incident affected: Transactions (Pay with Transfer/EFT).