Ghana: Downtime with processing partner

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 16:37 CET

Investigating

Ghana's central transfer switch is currently experiencing an unexpected downtime. This is affecting transfers to bank accounts.

Please note, mobile money transfers are not affected.

We're currently liaising with them to fix the issues and restore the service.
Posted Apr 22, 2025 - 13:54 CET
This incident affected: Transfers.