Delayed Transfers on Paystack
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 29, 2018 - 20:18 CET
Identified
We're experiencing an unusually high number of pending transfers. This is as a result of not getting a final response from our processing partners. This is being looked into.
Posted 3 months ago. Sep 29, 2018 - 12:56 CET
This incident affected: Transfers.