Issues accessing the Paystack Dashboard

Incident Report for Paystack

Resolved

This incident has now been resolved. Thank you for your patience!
Posted May 07, 2020 - 18:18 CET

Identified

We've identified an issue where merchants can't currently log in to the Paystack Dashboard (or sign up, for new merchants). Our Engineering Team is aware of this and currently pushing a fix
Posted May 07, 2020 - 18:01 CET
This incident affected: Dashboard.