South Africa: Capitec Performance Issues
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 23:04 CET
Monitoring
Success rates appear to be stable. We will continue to monitor.
Posted Dec 08, 2022 - 22:09 CET
Identified
Capitec is currently experiencing technical issues that are affecting card success rates.
Posted Dec 08, 2022 - 21:10 CET
This incident affected: Transactions (Cards).