Service degradation
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 18, 2023 - 15:55 CET
Monitoring
The team continues to monitor the affected services until the platform has fully stabilized.
Posted May 18, 2023 - 12:19 CET
Update
The team has made a change and we observe transactions being processed again. We continue to monitor closely.
Posted May 18, 2023 - 12:16 CET
Identified
The team has identified remediation steps
Posted May 18, 2023 - 12:15 CET
Investigating
Please note we have parts of our platform in a degraded state causing instability on some of our products. We are investigating this with urgency. We will update as soon as this has resolved.
Posted May 18, 2023 - 12:09 CET
This incident affected: API, Dashboard, Transfers and Transactions (Cards, Pay with Transfer/EFT).