Outage on NIBSS Direct Debit

Incident Report for Paystack

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2025 - 16:55 CET

Investigating

Direct Debit is currently unavailable across all banks. This is a result of a downtime with the central switch.

What is Affected?
- Attempts to charge already-linked accounts may fail.
- Attempts to link new bank accounts may also fail.


We are in communication with the service provider and will provide updates as soon as possible.
Posted Jul 29, 2025 - 16:15 CET
This incident affects: Transactions (Direct Debit).