South Africa: Increase in 3DS failure rate
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Aug 08, 2024 - 06:28 CET
Monitoring
Success rates have been stable since 01:50 SAST. We will continue to monitor.
Posted Aug 08, 2024 - 01:30 CET
Investigating
We're experiencing an increased failure rate for 3DS transactions. The issues has been escalated to our 3rd party partners.
Posted Aug 07, 2024 - 19:57 CET
This incident affected: Transactions (Cards).