Nigeria: Delay in processing First Bank transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 08:56 CET
Identified
Transfers to First Bank accounts in Nigeria might experience a slight delay due to a downtime from one of our technical partners. We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Mar 08, 2023 - 13:44 CET
This incident affected: Transfers.