Downtime on MTN Ghana Mobile Money Transactions & Transfers
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Sep 04, 2023 - 22:30 CET
Investigating
There is currently an issue with MTN Ghana affecting Mobile Money transactions & transfers in Ghana. The MTNGH team is working to have this issue fixed and will update us on their progress
Posted Sep 04, 2023 - 15:25 CET
This incident affected: Transactions (Mobile Money).