Downtime on Payment Pages
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 16:12 CET
Identified
We're having downtime on our Payment Page product and an error of "cURL error 51: Unable to communicate securely with peer: requested domain name does not match the server's certificate. (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)" is returned when opening a page.

Our team is currently working on this and will be deploying a fix shortly.
Posted Mar 10, 2020 - 16:06 CET
This incident affected: Payment Page.