Nigeria: United Bank for Africa(UBA) downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 07:57 CET

Update

We are continuing to investigate this issue.
Posted Apr 07, 2025 - 07:56 CET

Investigating

We're currently observing a high rate of failures for card transactions issued by UBA, as well as transfers to UBA bank accounts. This is due to a downtime on UBA's end.

We've informed their team and are actively working with them to resolve the issue as quickly as possible. We'll share an update once it's been resolved.
Posted Apr 07, 2025 - 07:52 CET
This incident affected: Transactions (Cards, Pay with Transfer/EFT) and Transfers.