South Africa: Increase in 3DS failure rate
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 08:19 CET
Monitoring
Success rates have stabilised since 8:35 SAST. We will continue to monitor.
Posted Nov 08, 2024 - 07:55 CET
Investigating
We're seeing an increased rate of failure for 3D Secure transactions. The issue has been escalated to our 3rd-party partners.
Posted Nov 08, 2024 - 06:56 CET
This incident affected: Transactions (Cards, QR).