Nigeria: Delay in Processing Paystack Titan Transactions

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Jul 17, 2024 - 17:50 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 17:43 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 17, 2024 - 16:51 CET

Investigating

We are noticing delays in confirming bank transfers to Paystack Titan accounts.

We are currently looking into this and working to resolve this issue as quickly as possible, we will provide an update as soon as it has been resolved.
Posted Jul 17, 2024 - 14:09 CET
This incident affected: Transactions (Pay with Transfer/EFT).