South Africa: EFT Ozow payments failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 08:57 CET
Monitoring
EFT Ozow transactions are processing successfully again. We will continue to monitor.
Posted Jan 30, 2025 - 08:20 CET
Investigating
EFT Ozow payments are currently failing. We have escalated the issue to Ozow.
Posted Jan 30, 2025 - 05:47 CET
This incident affected: Transactions (Pay with Transfer/EFT).