South Africa: Increased rate of failure for Standard Bank issued cards

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 15:09 CET

Monitoring

Transactions have been processing normally since 15:25 SAST. We will continue to monitor.
Posted Apr 02, 2025 - 14:43 CET

Investigating

We are seeing an increased rate of failure for 3DS transaction on cards issued by Standard Bank. The issue has been escalated to our third party partners.
Posted Apr 02, 2025 - 13:57 CET
This incident affected: Transactions (Cards, QR).