Downtime on Verve transactions
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted May 16, 2023 - 15:34 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2023 - 15:00 CET
Investigating
We are seeing an increase in failure rates on transactions through Verve cards.
We have notified the Verve team and are working with them to resolve this issue as quickly as possible, we will provide an update as soon as it has been resolved.
Posted May 16, 2023 - 14:46 CET
This incident affected: Transactions (Cards).