Temporary degradation of service
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 19:00 CET
Monitoring
We’ve implemented measures and affected services are now working fine. Our team would continue to monitor closely and make needed adjustments.
Posted Jan 25, 2023 - 18:14 CET
Investigating
We're investigating an issue causing a degradation of our service on our Payment Pages, Invoices and other Paystack resources like the Developer Documentation. We will provide an update on this issue shortly.
Posted Jan 25, 2023 - 16:56 CET
This incident affected: Checkout and Payment Page.