Nigeria: United Bank for Africa (UBA) Downtime

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 14:47 CET

Investigating

The scheduled maintenance by UBA is still ongoing. As a result, transactions on UBA-issued cards may continue to fail.

We’re in active contact with the bank and will provide updates as soon as we receive feedback.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 14, 2025 - 12:14 CET
This incident affected: Transactions (Cards).