Nigeria: Delay in processing bank transfers

Incident Report for Paystack

Resolved

This incident has been resolved.
Posted Apr 07, 2023 - 01:00 CET

Investigating

We have identified a fraction of Transfers into Access bank accounts in Nigeria that are yet to be fully processed.

We're working with them to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.
Posted Apr 06, 2023 - 13:19 CET
This incident affected: Transfers.