South Africa: Card transactions failing
Incident Report for Paystack
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 08:08 CET
Monitoring
Transactions have been processing normally again since 8:53 SAST. We will continue to monitor.
Posted Oct 16, 2023 - 07:57 CET
Investigating
Currently card transactions in South Africa are failing. The issue has been escalated to our 3rd-party partners.
Posted Oct 16, 2023 - 07:47 CET
This incident affected: Transactions (Cards).