South Africa: Card transactions failing

Incident Report for Paystack

Resolved

Transactions have been processing normally again since 19:58.
Posted Sep 27, 2023 - 19:07 CET

Investigating

Card transactions are currently failing. The issue has been escalated to our 3rd-party partners.
Posted Sep 27, 2023 - 18:15 CET
This incident affected: Transactions (Cards).